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Protocols and Editing Tips
Using Headings
Generally the page title is the first-order heading, and the main page subtitles begin with Heading 2. Further subheadings are used as needed. Logical
headings are important for scanning a page as well as for a helpful Table of Contents. Headings are set in the existing template.
If the headings go really deep (say, to fourth and fifth levels), then consider starting with level one instead of level two.
Think about the structure/presentation of your topic and how it will look in a Table of Contents – which you should use if your page requires much scrolling.
Tables of Contents, where topical headings and subheadings are well thought out, help viewers quickly find what they need right at the top of the page.

Placing Pages
Think about where your new page should go within the established hierarchy. In this ECOS Help wiki, each application has a parent page on the ECOS
Application Help wiki, and everything else is either content on the parent page or a child page of the parent page, on through the generations.
Organize it logically, and if it's a user manual or guide call it that, with the app abbreviation as the first word in the title (of at least the parent
page): e.g., "HabITS User Guide." In TAILS, for example, the Bull Trout Effects Take instructions (formerly COED and still a stand-alone user
guide) occur as a subset of Chapter 9, but the Bull Trout Effects-Take manual has its own chapters. So all of the TAILS chapters are identified as
"TAILS Chapter X. Title" and the Bull Trout Effects-Take Chapters are identified as "BT Effects-Take Chapter XI. Title." This keep people clear if
they randomly land on a Chapter page: they immediately know which app they're in.
Tell your users, via a note perhaps under the Table of Contents on a user guide page, that the page content is downloadable as a Word file
or PDF (recommend the PDF, it's an image of the page), should they desire a local file copy or printed paper copy.
The simplest way to move pages is, in the regular page view (not in the editor), to click Tools > View in hierarchy. There you can drag and drop
with impunity.

When to Add a Table of Contents
Required if your page has at least three headings and requires much scrolling, like this one! (So almost always.)
1. In Edit mode, place cursor at top of page ABOVE the first heading in the body.
2. Click Insert > Table of Contents
a. If it makes sense as shown in the macro previewer, set any parameters and click "Insert."
b. If it doesn't quite work, click "Cancel," rework your heading formatting, and try again.
3. The TOC macro tag will show in the editor.
4. Click "Save" when done.

When to Add a Change History
You can view the change history of any document by going to its page and clicking Tools > Page History. However, if the document is being created by
more than one person, requires approval, or might be audited, it might be best to add a Change History macro below the Table of Contents:
1.
2.
3.
4.
5.
6.

In the editor of the target page, place the cursor beneath the Table of Contents macro tag.
Click Insert > Other Macros > Confluence Content
Choose "Change History"
On the macro preview, set any parameters and click "Insert"
The "Change History" macro will show in the editor.
Click "Save."

Using Callout Boxes for Important Notes

These pull out and frame text that is especially important to make it stand out rather than be lost in a sea of characters. Find them under Insert > Other
Macros > Formatting, then scroll to the appropriate option (the four that follow have icons, but there are other options for setting off text). For example:

NEED MORE INFO?
This callout is good for extra information, say, about the version or history of an app or document and where to go for supplemental
information, that you want to stand out from the rest of the text.

NOTE (or, IMPORTANT NOTE)
In the help documents, we are using this callout for "Note:" statements, as for a cautionary or other important note—an extra detail,
something to pay attention to—but is short of a warning.
By the way, use the "Optional title" field in the previewer to type in the text you want to show, like "NEED MORE INFO?" or "GETTING HELP" or
"IMPORTANT NOTE" or whatever. I use caps because they stand out more, but whatever you do be consistent. On the one hand, consistency in
the many "IMPORTANT NOTE"s in TAILS are easy to eyeball as something to look for; while in other places, you might want to vary the title text
to draw the eye to unique sorts of notes and hint at the nature or importance of certain callout content, like "NEED MORE INFO?" vs. the generic
"NOTE."

TIP
This can be, for example, a helpful tip.

WARNING
This is a warning! (like, Achtung! Verboten! Don't do this! Caveat Emptor! 'S death!)

A NOTE ABOUT NOTES
In the editor, delete any spaces such that the callout box immediately follows the text describing it. Once you save, a little more space
will be added. Otherwise you get large gaps on the page. You can use "Preview" button at the lower right of the editor to check out the
final appearance before deciding and saving. (And sometimes, the spacing gets weird with Notes and tables, and won't stay saved
once you open the editor again; haven't figured out how to make it behave.)HabITS Accomplishment Type Definitions

Panels
I've used this macro to frame an exampole document on a help page or otherwise contain something unique, like a set of a couple examples. You can also
add a title, select background color and font color for the title bar, select a border color, and a background color for the text box. See examples at Creating
a Custom Letter for your IPaC Species Lists (letter content is within a panel) and HabITS Accomplishment Type Definitions (this uses tables to line out the
Examples, and the advantage here is table width conforms to text length; but you could do this):

EXAMPLES
Baseline inventories
Watershed assessments
Evaluations of management actions
Monitoring of changes over time

Common Actions
The "Insert" button on the editing toolbar is your source for all kinds of items and macros, from emoticons to a table of contents to any of a plethora of
handy macros. For macros, a few common ones are on the dropdown menus, and many more are under the "Other Macros" option, which itself has sets of
macros for different types of needs. Several especially useful ones are described below.

Adding Images

Images can be plucked from Word (copy/paste) or captured and then copied/pasted from those made with SnagIt or similar. There are a couple things you
can do once it's in Confluence (add a black border, resize), but if you are using added-on circles and arrows on figures, do those in the capture software
and then grab the whole image and place it in Confluence. (For any screenshots I added, I applied a medium blue border (and any circles, boxes, or
arrows around particular parts of the image) in SnagIt to all newly captured images—stands out better and looks nicer—before pasting it onto the
Confluence page.)
To resize, add a border, link to other content, or apply an interesting "effect," click on the image and then, in the tool bar that appears above or below it
(depending on where your view is):
1. Click on the pixel box and change the number to more or fewer, depending on whether you are enlarging or shrinking the graphic. 700-900 pixels
is a commonly good range, depending on the original and its contents–you want the text (if any) on the image to be about the same size as the
Confluence page text.
a. Smaller original images might still be very readable but will be naturally smaller in size, which is fine. Use good judgment; look at
examples in existing help manuals on this site.
b. The little presized blue squares and "original" button be used too, if they work for your purposes.
2. Click "Border" to add a thin black border around the image margins.
3. Click on "Link" to link the image to another page or item.
4. Click "Effects" to add an image effect ("curl shadow" is shown below, with a border).

Adding Attachments
Multiple attachments
Attachments, especially if you want to provide several, will stand out best (and are easily managed) using the Attachment macro, usually at the top or
bottom of a given page. To insert this macro:
In the editor, click Insert > Other Macros > Confluence Content
Choose the Attachments macro at the top, set any parameters, then click "Insert"
The Attachment macro tag will appear on the edit page.
Click "Save" when done.
Looks like this (notice that the attachments embedded throughout this page are displayed here):

Name

Size

Creator

Creation Date

Labels

Comment

PNG File image2013-3-4 16:3:9.png

4 kB

Juliette Wilson Mar 04, 2013
None
Edit Labels

PNG File image2013-3-4 16:2:31.png

4 kB

Juliette Wilson Mar 04, 2013
None
Edit Labels

PDF File FWS_map_template_specs.pdf

192 kB

Juliette Wilson Jan 25, 2013
None
Edit Labels

Microsoft Word Document Confluence_UsingTheEditor.docx 86 kB

Juliette Wilson Jan 25, 2013
None
Edit Labels

PDF File TransferInventory[1].pdf

164 kB

Juliette Wilson Jan 25, 2013
None
Edit Labels

You or anyone can now attach documents directly on the page using the macro.

Embedded attachments
If you just want to add just one attachment, or embed attachments in-text:
1.
2.
3.
4.
5.
6.

In the editor, place your cursor where you want to insert the file.
Click Insert > Attachment
Choose a file to upload.
Change the "Link Text" if desired (default is the filename, used in this example).
Click "Insert"
A link to the file will appear on the page, e.g.: Confluence_UsingTheEditor.docx
NOTE
If there also is an Attachment macro on the page, each embedded attachment will automatically be uploaded to it.

Adding Links
Links work much like individual attachments:
1. In the editor, place your cursor where you want to insert the link.
2. Click the "Link" button on the editor toolbar.
3. Choose the type of link (from Search, Recently Viewed (other pages you've visited on the wiki), Attachments (file types), Web Link (URL), or
Advanced [insert a link into the page using wiki markup–used for internal links within one page]).
4. Follow instructions to find and upload the link.
5. Change the "Link Text" if desired (default is the URL, filename, or selected text).
6. Click "Insert"
7. The link appears on the page (gave this example a name), e.g.: Confluence Help Page
(You can check that the link works from within the editor by clicking on the link text and choosing "Go to Link." In this way you can also edit or
remove the link.)

Line Spacing
When you use a numbering or bullet format, by default there is no line space between listed items. To add them (and once all the items are
listed), go back to the end of each item and the sentence leading into it, add a soft return: <<Shift>+<Enter>.
Sometimes the items are brief enough that the extra spacing isn't necessary. For longer bits, though, the space between the dense text of listed
items is helpful to readers. (And BTW, this spacing here took two soft returns.) THEN the next hard return inserts the next bullet (but at the end of
this sentence I again added one more soft return to insert the extra line space).
Numbering is thrown off whenever a hard return occurs between numbered items. Sometimes when you drop in a chunk or document's worth of
content (say, from Word) onto a Confluence page, the blank places where images are supposed to be will mess up the continuous numbering of
steps, for example. What I have done is to get all the numbered text together, with each item following the next, then go back in and use the soft
returns to add images or note callouts. That way you can get each numbered item to follow (with a hard return and pulling text into each proper
number spot) so that the numbering scheme works, THEN go back and add the interwoven figures and notes...using only soft returns to preserve
the numbering.
Also, know that imported numbered lists that LOOK like they're automatically following one another might not actually be, and you might have to
redo it to get the systematic numbering (with spacing and only hard returns between listed items) working properly in Confluence.
If this is confusing just play with it.

Permissions

If you are creating the page, you can restrict who sees it and/or who can edit it. To do so, click TOOLS > Restrictions. Then:
1. Click the radio button for "Restrict viewing of this page" OR "Restrict editing of this page" (or both in turn).
2. In either of those cases, click on "Person," unless you are creating and adding a Group (in which case click that instead).
3. Complete the "User details" (or Group Search)—normally a first and/or last name, or email—and click "Search."
4. Click the checkbox for the desired matches/names on the list that appears, then "Select User(s)."
5. The name(s) you selected will appear on the Page Restrictions form, under Viewing and/or Editing, depending on which you restricted.
6. Change your mind or make a mistake? Click "Remove restriction" to the right of the (offending) name.
7. NOTHING IS RESTRICTED unless you make it so. However, likely no one will likely find this until you activate the links in the application to the
user guides and other help materials on this site.
8. Once the pages on this site become available via links from the application, you'll want to remove any viewing restrictions or users won't
be able to see the pages so linked.

