Confluence Retirement

In an effort to consolidate USGS hosted Wikis, myUSGS’ Confluence service is scheduled for retirement on January 27th, 2023. The official USGS Wiki and collaboration space is now SharePoint. Please migrate existing spaces and content to the SharePoint platform and remove it from Confluence at your earliest convenience. If you need any additional information or have any concerns about this change, please contact myusgs@usgs.gov. Thank you for your prompt attention to this matter.

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

  • Install Anaconda without fouling the Windows environment (paths, registry) to break Esri's python stack
  • Configure Anaconda with the particular add-ons you want, and
  • Configure ArcGIS's Python so that it is aware of the appropriate Anaconda content.

The challenge here is that ESRI provides a very specific version of Python and libraries and you cannot easily get ArcGIS to use incompatible newer versions. This means that when exploiting non-ESRI provided modules that you gain via Anaconda, the Anaconda environment (including versions of standard library modules, for example, numpy) must be configured to be compatible with the ArcGIS "Python stack" for that release of the software (10.1, 10.2, 10.3, Pro).  

1) Install Anaconda

  1. go to http://continuum.io/downloads
  2. select for 32-bit python (because you should be compatible with the general/interactive version of python from ESRI)
  3. IMPORTANT: when installing, you will be asked whether to make the Anaconda Python the default version of Python and whether to add this to the PATH environment variable. Decline both options (or the ESRI python will stop working).

...